Monument very slow to display images after last update



  • Official comment
    Development Team

    Hi All,

    We have made several improvements over the last couple of updates and resolved the following important issues:

    • too many photos on Monument or on the iOS device was causing sluggishness or sometimes app crashes
    • intermittent connection issues when using remote access

    There's one more fix coming up with 2.17.3 where the Browse screen gets a complete overhaul. We're seeing 10x improvements in speed in our internal tests and we're hard at work to get this out to you.

    Gary Denyer if you are having this connection issues on the local network, this is not normal. We're reaching out to you to investigate this issue.

    Comment actions Permalink
  • Avatar
    Steve Sugrim

    There is definitely something up with this update. Everything was working and displaying fine. Not only is it not displaying, it will eventually crash, on all items - uploading, displaying photos, browsing. Is there a way to go back to the previous update?

    Comment actions Permalink
  • Avatar
    Terje Pedersen

    I have the same problem. 37000 pictures and 400 videos.

    Comment actions Permalink
  • Avatar
    Gary Denyer

    It's been two months - no reply here from Monument and the problems just keep getting worse!

    When successfully connected to Monument over 4G/WiFi:

    * On loading - Photos take over a minute to start showing, and even then they're just dotted around with the remainder being grey boxes.

    * Trying to use the browse tab is impossible as nothing loads - full stop, just a white screen

    That's when Monument actually connects. However, the connection to Monument itself is now incredibly patchy - my app keeps connecting for a few seconds and then dropping. Restart the app and you get a few seconds before dropping again. The App / Hardware always functioned perfectly up until 2.3.0 / 2.16.3 - its now horrendous to use! I've now had to change my workflow to first backup all my photoshoots to a NAS before putting the files anywhere the Monument as I've lost trust in it and am getting close to disconnecting and shelving it.


    Library size: 77,147 photos and 7,403 videos

    Phone: iPhone 7+ running IOS 13.2.3

    App version: 2.17.1

    Monument version: 2.4.0, connected over by Ethernet + WiFi

    Diagnostics information sent.

    Comment actions Permalink
  • Avatar
    Gary Denyer

    Thanks for the update (on here, and to Monument!). The latest 2.5.1 update hit my Monument about 12 hours after my post above and I have to say it's a huge improvement. The connection dropping issue was occurring over my network and with 4G, but it seems to be stable on both since the update.

    Browsing still doesn't work (I tested this morning, it took 12 minutes before anything showed up under 'People' - that's with no new photos being uploaded since I last managed to open it) - however, if a fix is coming shortly then that's not a problem.

    There was also a problem with the desktop application not uploading a number of photos when I tried to do so (it would do a few and then just hang). I haven't tested this again since 2.5.1 though so will give it another go this evening.

    Should the dropped connection issue reappear over my home network - I'll raise a ticket and provide detailed information about how the network is setup / configured in case it helps.


    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk